Ga naar inhoud

Welkom op PC Helpforum!
PC Helpforum helpt GRATIS computergebruikers. Ons team geeft via het forum professioneel antwoord op uw vragen en probeert uw pc problemen zo snel mogelijk op te lossen.

Word lid vandaag, plaats je vraag online en het PC Helpforum-team helpt u graag verder!


Rob Embrace

getal afronden naar vast gestelde waarde.

Aanbevolen berichten

Hallo,

 

Ik wil graag een willekeurig getal in een cel toetsen aan een vooraf gegeven reeks getallen en dan weergeven als een van die gegeven getallen.

Een beetje meer uitleg is wel op zijn plaats denk ik.

Er is een vast gestelde reeks getallen nl: 10, 16, 20, 25, 32, 35, 50, 63, 80 en 100. in A1 komt een getal bv 36  in A2 moet dan 50 komen. en als er in A1 24 komt dan moet er in A2 25 komen.

dus kijken waartussen de getallen vallen en dan het hoger gelegen getal noteren in A2.

 

Wie kan mij hier mee op weg helpen?

 

Al vast bedankt,

Rob

 

Deel dit bericht


Link naar bericht
Delen op andere sites


Als de 10 getallen in E1:E10 staan en de zoekwaarde in A1, typ dan in A2:

=ALS(A1<=10;10;ALS(AANTAL.ALS(E$1:E$10;A1)>0;VERT.ZOEKEN(A1;E$1:E$10;1;0);INDEX(E$1:E$10;VERGELIJKEN(A1;E$1:E$10)+1)))

Deel dit bericht


Link naar bericht
Delen op andere sites

Het kan nog wel iets korter:

=ALS(A1<=10;10;ALS(AANTAL.ALS(E$1:E$10;A1)>0;A1;INDEX(E$1:E$10;VERGELIJKEN(A1;E$1:E$10)+1)))

Je had niet vermeld wat er moet gebeuren als er een getal groter dan 100 wordt ingevoerd, anders had daar ook nog rekening mee gehouden kunnen worden.

aangepast door alpha

Deel dit bericht


Link naar bericht
Delen op andere sites

4 minuten geleden, Rob Embrace zei:

Als de zoekwaarde 0 is komt er nu 10 in A2.

Is het mogelijk dat er dan nul wordt weer gegeven?

Natuurlijk:

=ALS(A1<1;0;ALS(A1<10;10;ALS(AANTAL.ALS(E$1:E$10;A1)>0;A1;INDEX(E$1:E$10;VERGELIJKEN(A1;E$1:E$10)+1))))

Deel dit bericht


Link naar bericht
Delen op andere sites

Logo

OVER ONS

PC Helpforum helpt GRATIS computergebruikers sinds juli 2006. Ons team geeft via het forum professioneel antwoord op uw vragen en probeert uw pc problemen zo snel mogelijk op te lossen. Word lid vandaag, plaats je vraag online en het PC Helpforum-team helpt u graag verder!

×
×
  • Nieuwe aanmaken...