Ga naar inhoud

Logitech dicht beveiligingslekken in updater Harmony Hub


Aanbevolen berichten

Elektronicafabrikant Logitech heeft een update uitgebracht voor de Harmony Hub, een apparaat waarmee het mogelijk is om 250.000 verschillende apparaten in huis te bedienen. Via verschillende lekken in de Harmony Hub was het mogelijk voor een lokale aanvaller om roottoegang te krijgen.

Zo bleek dat er geen wachtwoord voor het rootaccount was ingesteld en dat ongeldige tls-certificaten door de updater werden genegeerd. Hierdoor was het voor een aanvaller mogelijk om updateverzoeken die van de Harmony Hub afkomstig waren te onderscheppen. Het apparaat controleert geregeld of er aanvullende software of updates beschikbaar zijn. De aanvaller had het onderschepte updateverzoek naar een kwaadaardig package kunnen laten wijzen, dat vervolgens door de updater werd gedownload en uitgevoerd.

Op deze manier was het mogelijk om SSH op de Harmony Hub in te schakelen. Aangezien er voor het rootaccount geen wachtwoord was ingesteld had een aanvaller vervolgens met de gebruikersnaam root en een leeg wachtwoord via SSH kunnen inloggen. Logitech werd in januari door securitybedrijf FireEye ingelicht en bracht in april firmware 4.15.96 uit om het probleem te verhelpen. Details over de kwetsbaarheden zijn nu bekendgemaakt. Daarop heeft Logitech gebruikers via Twitter gewaarschuwd om de firmware-update te installeren mocht dat nog niet zijn gedaan.

 

 

bron: security.nl

Link naar reactie
Delen op andere sites


 Delen

×
×
  • Nieuwe aanmaken...