Ga naar inhoud

Sommen.als uit meerdere kolommen


Teddycares
 Delen

Aanbevolen berichten

Ik heb een bestand waarbij in meerdere kolommen gezocht moet worden naar een bepaalde datum welke in verschillende kolommen meerdere keren kan voorkomen. 

Nu gebruik ik de volgende combinatie van formules

SOMMEN.ALS(xx!M:M;xx!Q:Q;A376;xx!B:B;"x")+SOMMEN.ALS(xx!M:M;xx!P:P;A376;xx!B:B;"x")+SOMMEN.ALS(xx!M:M;xx!R:R;A376;xx!B:B;"x")+SOMMEN.ALS(xx!M:M;xx!S:S;A376;xx!B:B;"x")+SOMMEN.ALS(xx!M:M;xx!t:t;A376;xx!B:B;"x") etc etc

Aangezien het een veld van 700 aansluitende kolommen is, wordt dit ondoenlijk en hoop ik dat er een simpelere weg is.

Wie kan me helpen ?

aangepast door Teddycares
taalfout
Link naar reactie
Delen op andere sites


Je moet niet het gehele werkblad aan rijen willen gebruiken (dat zijn meer dan 1 miljoen cellen per kolom, voor 700 kolommen dus 700.000.000 cellen, daar loopt Excel op vast) als je slechts een beperkt aantal rijen daarvan gebruikt. Stel dat je tabel 2000 rijen beslaat, dan zou je kunnen gebruiken (in te voeren via Ctrl-Shift-Enter, vergeet dat niet !) :

=SOM(ALS(xx!B2:B2000="x";ALS(xx!P2:AAN2000=A376;xx!M2:M2000)))

Link naar reactie
Delen op andere sites


 Delen

×
×
  • Nieuwe aanmaken...