Ga naar inhoud

Kruislings zoeken in tabel


mike_v
 Delen

Aanbevolen berichten

Hallo,

 

ik ben opzoek naar een formule of methode om een waarde uit een tabel weer te geven door middel van twee waarden in te vullen.

 

Ik heb dit reeds deels kunnen oplossen door verticaal te zoeken, maar dit zou ik moeten kunnen combineren met horizontaal zoeken.

 

Ter verduidelijking een screenshot;

 

Knipsel.thumb.JPG.4a000d1cc3f509c36b2e9b75ea04ffcd.JPG

 

In Kolom G (bemestingsadvies) zou ik een waarde moeten verkrijgen uit tabel B9:E31, afhankelijk van de gegevens uit E2:E6 en F2:F6. Hierdoor zou ik de kolommen H I J en K weg kunnen laten en wordt het overzichtelijker.

 

Iemand die hier een oplossing voor heeft?

 

Bij voorbaat dank.

Link naar reactie
Delen op andere sites


Ondertussen is het, met hulp van de broer, gelukt door een combinatie van ALS functies en de verticaal zoeken functie.

 

Voor de geïnteresseerde;

 

Quote

=ALS(Tabel4[[#Deze rij];[Grondsoort]]=$A$2;VERT.ZOEKEN(Tabel4[[#Deze rij];[Gezaaide teelt]];Tabel5;2;ONWAAR);ALS(Tabel4[[#Deze rij];[Grondsoort]]=$A$3;VERT.ZOEKEN(Tabel4[[#Deze rij];[Gezaaide teelt]];Tabel5;3;ONWAAR);ALS(Tabel4[[#Deze rij];[Grondsoort]]=$A$4;VERT.ZOEKEN(Tabel4[[#Deze rij];[Gezaaide teelt]];Tabel5;4;ONWAAR);ALS(Tabel4[[#Deze rij];[Grondsoort]]=$A$5;VERT.ZOEKEN(Tabel4[[#Deze rij];[Gezaaide teelt]];Tabel5;5;ONWAAR);"Ongeldig type"))))

 

Toch nog bedankt voor het meedenken!

Link naar reactie
Delen op andere sites


Het kan ietsie pietsie korter.

Ik geef trouwens de voorkeur aan Index Vergelijken

 

=ALS.FOUT(INDEX(Tabel4[[Leemachtig zand]:[Ziltige klei]];VERGELIJKEN(E2;Tabel4[Teelt];0);VERGELIJKEN(F2;Tabel4[[#Kopteksten];[Leemachtig zand]:[Ziltige klei]];0));"")

Eventjes je plaatje door OCR gehaald en een voorbeeldje gemaakt.

Teelt.xlsx

Link naar reactie
Delen op andere sites


 Delen

×
×
  • Nieuwe aanmaken...