Ga naar inhoud

Aanbevolen berichten

Gegeven: Maanden in kolom A; Codes in kolom C; Bedragen in kolom D

Probleem: Ik wil de som maken (in bvb E1) van de bedragen in het bereik (D2:18) van de maand januari(A2:A18) als de code 1 is(C2:C18)Volgende formule werkt niet;hoe moet het wel?

={SOM(ALS(EN(MAAND($A$2:$A$18)=1;$C$2:$C$18=1);$D$2:$D$18))}

aangepast door Ypsolona
Verduidelijken
Link naar reactie
Delen op andere sites


  • 3 weken later...

Ypsolona,

Met deze gaat het zeker lukken.

=SOMPRODUCT((A2:A18=1)*(C2:C18=1)*(D2: D18))

Deze kan ook, met in F1 de maand, en in G1 de code

=SOMPRODUCT((A2:A18=F1)*(C2:C18=G1)*(D2: D18))

Groet bucky

Edit: Verwijder in beide formules tussen : D18 de spaties, reden is dit: D2:D18

aangepast door bucky
Edit
Link naar reactie
Delen op andere sites

Ypsolona,

Met deze gaat het zeker lukken.

=SOMPRODUCT((A2:A18=1)*(C2:C18=1)*(D2: D18))

Deze kan ook, met in F1 de maand, en in G1 de code

=SOMPRODUCT((A2:A18=F1)*(C2:C18=G1)*(D2: D18))

Groet bucky

Edit: Verwijder in beide formules tussen : D18 de spaties, reden is dit: D2:D18

Dank;werkt eindelijk perfect (met kleine aanpassing: =SOMPRODUCT((MAAND(A2:A18)=1..........)

Link naar reactie
Delen op andere sites


Gast
Dit topic is nu gesloten voor nieuwe reacties.
 Delen

×
×
  • Nieuwe aanmaken...