Ga naar inhoud

nachtvergoeding


tjalk
 Delen

Aanbevolen berichten

Goedemiddag,

 

ik zou graag een automatische vergoeding berekening krijgen van de uren tussen 21:00 en 05:00 uur.

 

Voorbeeld:

begin         Eind             vergoeding

03:15        02:00            6:45 uur                            begin 03:15 = 1:45 uur (voor 5:00 uur)    eind 6:45 = 5 uur  (uren tussen 21 en 05:00 uur)

19:45        17:00            8 uur                                

7:15          1:45             4:45 uur

Link naar reactie
Delen op andere sites

57 minuten geleden, tjalk zei:

Goedemiddag,

 

ik zou graag een automatische vergoeding berekening krijgen van de uren tussen 21:00 en 05:00 uur.

 

Voorbeeld:

begin         Eind             vergoeding

03:15        02:00            6:45 uur                            begin 03:15 = 1:45 uur (voor 5:00 uur)    eind 6:45 = 5 uur  (uren tussen 21 en 05:00 uur)

19:45        17:00            8 uur                                

7:15          1:45             4:45 uur

heb een foutje gemaakt,  eind 02:00 uur = 5 uur (uren tussen 21 en 05:00 uur)

Link naar reactie
Delen op andere sites

3 uren geleden, tjalk zei:

heb een foutje gemaakt,  eind 02:00 uur = 5 uur (uren tussen 21 en 05:00 uur)

Uitgaande van 03:15 - 02:00 uur is die 5 uur ook nog fout als (zoals je schrijft) de uren tussen 21:00 en 05:00 uur gerekend moeten worden. Want:

1e nacht: van 03:15 - 05:00 uur = 01:45 uur

2e nacht: van 21:00 - 03:15 uur = 06:15 uur

Samen is dat 08:00 uur.

Link naar reactie
Delen op andere sites

23 minuten geleden, alpha zei:

Uitgaande van 03:15 - 02:00 uur is die 5 uur ook nog fout als (zoals je schrijft) de uren tussen 21:00 en 05:00 uur gerekend moeten worden. Want:

1e nacht: van 03:15 - 05:00 uur = 01:45 uur

2e nacht: van 21:00 - 03:15 uur = 06:15 uur

Samen is dat 08:00 uur.

Hallo Alpha,

als ik om 3:15 begin heb ik al recht op 1:45 uur vergoeding (begonnen voor 05:00 uur) , einde werk is de volgende morgen 02:00 uur.  krijg dus hier vergoeding vanaf 21:00 uur tot 02:00 uur = 5 uur + 1:45 uur = 6:45 uur. 

Link naar reactie
Delen op andere sites

46 minuten geleden, alpha zei:

Met begin- en eindtijd in A1 en B1, probeer dit in C1:

 


=ALS(EN(A1>0;B1>0);MAX(5/24-A1;0)+ALS(B1<A1;3/24+B1-MAX(A1-21/24;0)-MAX(B1-5/24;0);+ALS(EN(A1>0,5;B1>0,5);MAX(B1-21/24-MAX(A1-21/24;0))));"")

 

test.xlsx        Hallo Alpha, zit nog een foutje in (zie bestand) als er voor 05:00 uur begonnen wordt en na 21:00 uur gestopt wordt is de berekening niet goed

Link naar reactie
Delen op andere sites

=ALS(EN(A1>0;B1>0);MAX(5/24-A1;0)+ALS(B1<A1;3/24+B1-MAX(A1-21/24;0)-MAX(B1-5/24;0);+ALS(EN(A1>0,5;B1>0,5);MAX(B1-21/24;0)-MAX(A1-21/24;0);+ALS(EN(A1<0,5;B1>0,5);MAX(B1-21/24;0);-ALS(EN(A1<0,5;B1<0,5;A1<B1);MAX(5/24-B1;)))));"")

Link naar reactie
Delen op andere sites

9 minuten geleden, alpha zei:

);+

 

9 minuten geleden, alpha zei:

);+

 

9 minuten geleden, alpha zei:

);+

 

23 minuten geleden, alpha zei:

 


=ALS(EN(A1>0;B1>0);MAX(5/24-A1;0)+ALS(B1<A1;3/24+B1-MAX(A1-21/24;0)-MAX(B1-5/24;0);+ALS(EN(A1>0,5;B1>0,5);MAX(B1-21/24;0)-MAX(A1-21/24;0);+ALS(EN(A1<0,5;B1>0,5);MAX(B1-21/24;0);-ALS(EN(A1<0,5;B1<0,5;A1<B1);MAX(5/24-B1;)))));"")

 

Hallo Alpha, deze is helemaal top, bedankt voor je snelle en perfecte oplossing.  gr Tjalk

Link naar reactie
Delen op andere sites

  • 3 weken later...
Op ‎17‎-‎5‎-‎2018 om 22:39, tjalk zei:

 

 

 

Hallo Alpha, deze is helemaal top, bedankt voor je snelle en perfecte oplossing.  gr Tjalk

 

Op ‎17‎-‎5‎-‎2018 om 22:39, tjalk zei:

 

Hallo Alpha, er zit toch nog een klein foutje in, als iemand om 12:00 uur begint en stopt om 23:00 dan berekent hij niet de uren boven 21:00.  (11:45 uur en 12:15 uur wel)

 

 

Link naar reactie
Delen op andere sites

 Delen

×
×
  • Nieuwe aanmaken...