Ga naar inhoud

ALS.Functie geneste formule


Aanbevolen berichten

Beste, 

Ik zou de formule beneden aan elkaar willen krijgen. Afzonderlijk werkt hij maar ik krijg hem niet genest. Kan iemand me hiermee helpen:

=ALS(EN(LINKS($A66;2)="ma");ALS(IS.ONEVEN(C66);$D$171;($D$172));
ALS(EN(LINKS($A66;2)="di");ALS(IS.ONEVEN(C66);$D$176;($D$177));
ALS(EN(LINKS($A66;2)="wo");ALS(IS.ONEVEN(C66);$D$181;($D$182));
ALS(EN(LINKS($A$66;2)="do");ALS(IS.ONEVEN(C66);$D$186;($D$187));
ALS(EN(LINKS($A$66;2)="vr");ALS(IS.ONEVEN(C66);$D$191;($D$192));
ALS(LINKS($A$66)="za";$D$198;($D$199);
ALS(LINKS($A$66;2)="zo";$D$199;$D$198)))))))

 

Met dank

Link naar bericht
Delen op andere sites

  • Reacties 20
  • Aangemaakt
  • Laatste reactie

Beste reacties in dit topic

Beste reacties in dit topic



Hij moet volgens mij toch enkel kijken of in dit geval cel D66 even of oneven is.

Indien oneven vul in D171

Indien even vul in D172

Indien tekst "ma"

 

zo dan ook voor "di", "woe" enz......

De formule heeft perfect gewerkt tot ik argument even of oneven toevoegde.

 

Zit alleen vast dit extra argument toe te voegen.

Ik lees dat Excel tot 64 argumenten aankan doch ik krijg ze niet genest

Link naar bericht
Delen op andere sites

Beste Haije,

Ik maak dan volgende formule naar je voorbeeld:

=ALS(EN(LINKS($A66;2)="ma";IS.ONEVEN(C66));$D$171;$D$172);ALS(EN(LINKS($A66;2)="di";IS.ONEVEN(C66));$D$176;$D$177);ALS(EN(LINKS($A66;2)="woe";IS.ONEVEN(C66));$D$181;$D$182);ALS(EN(LINKS($A66;2)="do";IS.ONEVEN(C66));$D$186;$D$187);ALS(EN(LINKS($A66;2)="vr";IS.ONEVEN(C66));$D$191;$D$192);ALS(LINKS($A66;2)="za";$D$198;$D$199;ALS(LINKS($A66;2)="zo";$D$199;$D$198)

 

Doch krijg weer de mededeling dat ik teveel argumenten heb toegevoegd

Link naar bericht
Delen op andere sites
Gast
Dit topic is nu gesloten voor nieuwe reacties.

×
×
  • Nieuwe aanmaken...