Ga naar inhoud

ALS.Functie geneste formule


Aanbevolen berichten

hulsm,

 

Een ALS-formule bestaat uit 

- een (set met) voorwaarde(n)

- dan de waarde als aan die voorwaarde(n) voldaan wordt

- tenslotte de waarde als niet aan de voorwaarde(n) voldaan wordt.

 

In jouw formule gaat dat goed in de groene tekst

=ALS(EN(LINKS($A66;2)="ma";IS.ONEVEN(C66));$D$171;$D$172);ALS(EN(LINKS($A66;2)="di";IS.ONEVEN(C66));$D$176;$D$177);ALS(EN(LINKS($A66;2)="woe";IS.ONEVEN(C66));$D$181;$D$182);ALS(EN(LINKS($A66;2)="do";IS.ONEVEN(C66));$D$186;$D$187);ALS(EN(LINKS($A66;2)="vr";IS.ONEVEN(C66));$D$191;$D$192);ALS(LINKS($A66;2)="za";$D$198;$D$199;ALS(LINKS($A66;2)="zo";$D$199;$D$198)

maar alles wat in het rood staat kan niet meer in die cel, want de formule is al compleet.

 

 

 

Link naar bericht
Delen op andere sites

  • Reacties 20
  • Aangemaakt
  • Laatste reactie

Beste reacties in dit topic

Beste reacties in dit topic

Begrijp ik niet want ik gebruik al jaren deze formule:

=ALS(LINKS($A72;2)="ma";$D$172;ALS(LINKS($A72;2)="di";$D$177;ALS(LINKS($A72;2)="wo";$D$182;ALS(LINKS($A72;2)="do";$D$187;ALS(LINKS($A72;2)="vr";$D$192;ALS(LINKS($A72;2)="za";$D$198;ALS(LINKS($A72;2)="zo";$D$199)))))))

 

Deze werkt PRIMA, enkel de bijkomende afweging IS.ONEVEN zorgt voor problemen.

 

 

Link naar bericht
Delen op andere sites

Beste,

Maak eens een klein voorbeeld (een paar cellen) waaruit ik of  Haije  kan afleiden wat je wilt bereiken.

Zonder de overbodige kleurboek,

Ik wil je echt niet beledigen, maar ik begrijp het niet, je file werkt voor geen meter,maar je kleurtjes zijn in orde, waarom niet eerst je bestand in orde krijgen,????

Link naar bericht
Delen op andere sites

Beste Haije en dotchiejack,

 

Dit document werkt al meer dan tien jaar perfect en wordt dagelijks door dertig mensen gebruikt. De kleurtjes :-) zijn er zodat ze zien in welk luik ze werken.

Ik tracht enkel een toevoeging te doen voor mensen die anders werken in  EVEN en ONEVEN weken.

 

Ik voeg een duidelijke bijlage toe met mijn vraag

 

@popipipo, dat VERT.ZOEKEN is me nog onbekend ik ga me er wat in verdiepen, dank alvast.

 

Hopelijk is deze bijlage wat duidelijkerVoorbeeld Probleem PC helpforum.xlsm

Link naar bericht
Delen op andere sites

hulsm,

 

in je originele formule

=ALS(LINKS($A72;2)="ma";$D$172;ALS(LINKS($A72;2)="di";$D$177;ALS(LINKS($A72;2)="wo";$D$182;ALS(LINKS($A72;2)="do";$D$187;ALS(LINKS($A72;2)="vr";$D$192;ALS(LINKS($A72;2)="za";$D$198;ALS(LINKS($A72;2)="zo";$D$199)))))))

zet je op de plaats van "waarde als NIET voldaan wordt aan voorwaarde" opnieuw een ALS-formule

in je nieuwe formule

=ALS(EN(LINKS($A66;2)="ma";IS.ONEVEN(C66));$D$171;$D$172);ALS(EN(LINKS($A66;2)="di";IS.ONEVEN(C66));$D$176;$D$177);ALS(EN(LINKS($A66;2)="woe";IS.ONEVEN(C66));$D$181;$D$182);ALS(EN(LINKS($A66;2)="do";IS.ONEVEN(C66));$D$186;$D$187);ALS(EN(LINKS($A66;2)="vr";IS.ONEVEN(C66));$D$191;$D$192);ALS(LINKS($A66;2)="za";$D$198;$D$199;ALS(LINKS($A66;2)="zo";$D$199;$D$198)

zet je op die plaats een verwijzing (het rode deel) en alles wat daarna komt is volgens de excelregels teveel.

 

Je zult dus het rode deel moeten vervangen door een nieuwe ALS

 

Link naar bericht
Delen op andere sites

Beste,

 

Het is ondertussen gelukt met volgende formule:

=ALS(IS.EVEN($C6);ALS(WEEKDAG($B6;2 )=1;$D$172;ALS(WEEKDAG($B6;2 )=2;$D$177;ALS(WEEKDAG($B6;2 )=3;$D$182;ALS(WEEKDAG($B6;2 )=4;$D$187;ALS(WEEKDAG($B6;2 )=5;$D$192;ALS(WEEKDAG($B6;2 )=6;$D$198;ALS(WEEKDAG($B6;2 )=7;$D$199)))))));ALS(WEEKDAG($B6;2 )=1;$D$171;ALS(WEEKDAG($B6;2 )=2;$D$176;ALS(WEEKDAG($B6;2 )=3;$D$181;ALS(WEEKDAG($B6;2 )=4;$D$186;ALS(WEEKDAG($B6;2 )=5;$D$191;ALS(WEEKDAG($B6;2 )=6;$D$198;ALS(WEEKDAG($B6;2 )=7;$D$199))))))))

 

Dank voor de hulp, was m'n eerste keer op dit forum. De volgende keer tracht ik mijn vraagstelling meer to the point te maken

Link naar bericht
Delen op andere sites
Gast
Dit topic is nu gesloten voor nieuwe reacties.

×
×
  • Nieuwe aanmaken...